专职交易:趋势跟踪利器之二——自适应均线系统
技术指标 均线 原创    2021-03-22 17:36:24    536    0    0

  • 期货开户:手续费仅在交易所基础上加1分钱,不限资金量(点击了解详情>>>)
  • 股票开户:手续费万分之1.5以内,无资金量要求(点击了解详情>>>)
  • 专职交易:从交易新手到老手的阅读清单
  • 趋势跟踪是一种比较简单有效的交易模式。而要跟踪好趋势,首先必须要做到准确有效的识别趋势。
    识别趋势的方法和工具有很多,其中最简单有效的就是均线。本人所用的ATR通道指标,就是基于均线衍生出来的一个指标。
    要用好均线,首先要解决的一个问题就是均线的周期参数。按照周期长短,均线一般可以分为短期均线、长期均线,这两种均线各有优缺点。
    • 短期均线比较灵敏,可以更快的判断趋势,但遇到震荡,不能很好的过滤市场走势杂波。
    • 长期均线能够比较准确的判断趋势,过滤掉大部分走势杂波,但又存在比较严重的滞后问题。长期均线确认趋势形成的时候,往往已经走了一大段了。
     
    理想的解决方案是:
    1. 当市场进入横盘震荡时,我们使用长期均线,过滤掉大部分的杂波。
    2. 当市场进入单边趋势时,我们使用短期均线,能够比较快速的判断趋势的形成和结束。
    那么,这种比较理想的均线是否存在?
    答案是确实存在,这种均线就是自适应均线,如下图所示:
    上图中,红色框区域,价格走势进入单边上涨趋势,自适应均线自动缩短周期,采用短期均线,转为向上移动;绿色框位置,市场走势进入横盘震荡,自适应均线自动延长周期,采用长期均线,转为横向移动。
     
    自适应均线的原理:
    自适应均线是普通均线的衍生,在普通均线基础上增加了根据市场走势调节周期参数的功能,它是通过测量一段时间内价格变动的速率,根据速率来调节均线的周期参数,从而达到根据走势自动转换周期的目的。
    测量价格变动速度的方法是在指定的一段时间内,计算每个周期价格变动的累加,并用整个时间周期的价格总体变动和每个周期价格变动的累加值的比率作为这个周期价格变动的速率。
    1. 如果在一定周期内,价格持续上涨或下跌(单边走势),那么变动速率=1,此时对应的是最短的均线,相当于2日均线(日线周期);
    2. 如果在一定周期内,价格涨跌幅度为0(横盘震荡),那么变动速度=0,此时对应的是指定周期内的最长周期均线,比如自适应均线周期参数为30,那么对应的就是30日均线(日线周期);
    日常的价格走势内,走势的变动速率会在0和1之间变动,对应的均线参数就会在2到最长周期之间变动。

    考夫曼自适应均线指标:
    根据自适应均线的原理,我们可以编制自适应均线指标,比较经典的就是考夫曼自适应均线指标,代码如下(通达性编译通过,N为自适应均线的周期参数):
    DIR:=ABS(CLOSE-REF(CLOSE,N)); {整个周期价格的总体变动}
    VIR:=SUM(ABS(CLOSE-REF(CLOSE,1)),N); {每个周期价格变动累加}
    ER:=DIR/VIR; {价格变动速率}
    CS:=ER*(2/3-2/(N+1))+2/(N+1);;
    CQ:=CS*CS;
    MAN:EMA(DMA(CLOSE,CQ),2),COLORGREEN;

    {加上变色功能}
    IF(MAN>REF(MAN,1),MAN,DRAWNULL),COLORRED,LINETHICK4,POINTDOT;
    IF(MAN>REF(MAN,1),MAN,DRAWNULL),COLORRED,LINETHICK1;
    IF(MAN=REF(MAN,1),MAN,DRAWNULL),COLORWHITE,LINETHICK4,POINTDOT;
    IF(MAN=REF(MAN,1),MAN,DRAWNULL),COLORWHITE,LINETHICK1;
    IF(MAN<REF(MAN,1),MAN,DRAWNULL),COLORGREEN,LINETHICK1;
    IF(MAN<REF(MAN,1),MAN,DRAWNULL),COLORGREEN,LINETHICK4,POINTDOT;
    说明:注意添加参数 N

    交易规则:
    1. 当自适应均线向上移动或者向下移动的时候,表示市场进入单边上涨或下跌趋势,我们的操作策略转为趋势跟踪,进场做多或做空;
    2. 当自适应均线横盘移动的时候,表示市场进入震荡行情,我们的操作策略转为震荡策略,空仓等待,或者短线抄底摸顶(不建议)。



    本人的微信公众号(原股海藏经楼)重新开通,主要用于分享一些原创的个人交易经验、感悟和方法,欢迎关注!

    关注方法(任选一种):

    1、微信->点右上角+号->添加朋友->公众号->搜索“hszhangjb"->点"张金彪hs",关注即可。

    2、用微信扫下方二维码关注:

    

    Pre: ATR通道指标使用说明

    Next: 专职交易:微信公众号开通

    关注股海藏经楼,学习交易知识(点击关注)
    Table of content